Foro The Movies Cinema Machinima Español
BIENVENIDO a la comunidad sobre el juego The Movies y otros Machinimas. Aquí encontraras una gran familia, ayuda, etc, y sobre todo compartir la afición que nos gusta a todos, que es crear películas con motores de juegos. Regístrate o identifícate para quitar la publicidad y poder participar en el foro.
Si tienes problemas con el registro, en el foro Bienvenidos hay un post-it abierto a invitados.
------------------------------------------------------------
WELCOME to the community about the game The Movies and other Machinimas. Here you will find a great family, help, etc, and above all share the hobby that we like to all, which is to create movies with game engines. Register or identify to remove the publicity and to participate in the forum. If you have problems with the registration, in the Welcome forum there is a post-it open to guests.

problema con Blender

Página 1 de 2. 1, 2  Siguiente

Ir abajo

problema con Blender Empty problema con Blender

Mensaje por gabriel el Mar 26 Ene 2016, 20:07

Hola, buenas...
Abro un nuevo hilo por no sobrecargar los que tengo planteados. Sigo montando props humanos estaticos personalizados. Pero, sin saber porque, una vez creo la cabeza personalizada, y siguiendo el protocolo del tutorial, la exporto en formato *.msh.

Mirad que me sale cuando la importo para añadirle el pelo y el traje:

problema con Blender P87jLVZ

Solo sale el esqueleto. La pregunta del millon: Que he hecho mal?
gabriel
gabriel
 

Mensajes : 283
Fecha de inscripción : 21/10/2010

Ver perfil de usuario

Volver arriba Ir abajo

problema con Blender Empty Re: problema con Blender

Mensaje por Regolero el Mar 26 Ene 2016, 20:41

si no te sale es porque no lo has exportado bien

lo primero que tienes que mirar al exportar la cabeza personalizada es si se exportó bien, mirando la pantalla negra del blender si sale que finalizó correctamente la exportación.

También sino recuerdo mal y que me dolió mucho la cabeza era el hueso neck contecte o algo así, que me daba problemas. Borra ese hueso de la lista del esqueleto cuando elijes a donde pegarlo y exporta tu prop.
Regolero
Regolero
Alcaide

Rol : Director
Mensajes : 9176
Fecha de inscripción : 17/08/2010
Localización : Sevilla
. : Totems 2010: 2º Mejor Cortometraje, 2º Mejor Dirección, 2º Mejor Guión, 2º Mejor Tráiler . : Águilas 2011: 1º Mejor Ambientacion, 1º Mejor FX, 2º Mejor Sonido . : Recreaciones clásicas: The Ring

Ver perfil de usuario

Volver arriba Ir abajo

problema con Blender Empty Re: problema con Blender

Mensaje por Capitan Blackjoker el Mar 26 Ene 2016, 21:15

Shhh, Stop the press! ¡Parad las rotativas!
Antes que nada. Regolero se refiere a que cuando Blender se inicia, lo hace a través de Python, un sistema para poder usar el programa, (por eso abren dos ventanas),

Una parte es la de Blender y la de fondo negro como si fuera  el MS-DOS, es la famosa consola de Python, que cuando algo falla nos informa con ese "cariñoso" mensaje de ERROR: Check python console.

problema con Blender E5n5n9

Si has exportado bien, te saldrá toda la relación de materiales, texturas, shapes, anclajes de animación y grupos que tiene la mesh. Y finalmente, el mensaje deseado: finished exporting, la ruta donde esta (incluido el nombre del archivo) y el tiempo usado para su exportación:
problema con Blender 2q2keur

Pero si hay algo mal, te dirá en que ha fallado y porque, en una lista de errores de comandos.

Aunque para no liarte más, cuando te aparezca una de estas cosas, nos haces un pantallazo para ahorrarte (y ahorrarnos) más problemas y listos. Ahora dejémos la Python console por hoy.

Dicho esto, Gabriel; en tu pantallazo se muestra solo el esqueleto y el empty, entiendo que al usar el "Append or link", no has seguido los pasos bien.
Tu problema es que no hay los objetos. O bien no los has puesto en el archivo o los has borrado. Prueba de nuevo a meter los objetos que forman tu cabeza, siguiendo la tutorial que te hice para aprender el uso de esta técnica con calma.

Antes de exportar tu mod, recuerda lo siguiente:

1. Guarda en formato .blend, como se indica en la tutorial (que explica como hacerlo), para que se eliminen los materiales y texturas NO asociadas. así eliminas posibles problemas de exportación.

2. Que los objetos y elementos estén bien asociados.

3. Y finalmente, ahora que ya tienes cierto nivel... Debes usar la herramienta que te ahorrará dolores de cabeza ( y quizás a nosotros XDXDXD):

El Preflight de TM

Con esto, sabrás como están las cosas en tu Mesh antes de exportar; por fin, dejarás de darte cabezazos por no saber qué ocurre.
CUIDADO: No es la panacea; Solo una utilidad que te dará más "finura" para hallar los errores de un mod.
Nos vemos.


problema con Blender B%2526B%2BLogo

"El Norte sin el Sur no es nada. Lo importante no es el destino ni el inicio; Solo lo es, el camino y como has viajado por él."
Capitan Blackjoker
Capitan Blackjoker
 

Mensajes : 1454
Fecha de inscripción : 17/08/2010
Localización : A bordo, como si no?
. : Águilas 2011: 2º Mejor Actor Secundario

Ver perfil de usuario

Volver arriba Ir abajo

problema con Blender Empty Re: problema con Blender

Mensaje por gabriel el Lun 15 Feb 2016, 12:58

perdonad la tardanza. Resuelto. era un problema de exportacion por no haber seguido correctamente el protocolo. muchas gracias.
gabriel
gabriel
 

Mensajes : 283
Fecha de inscripción : 21/10/2010

Ver perfil de usuario

Volver arriba Ir abajo

problema con Blender Empty Re: problema con Blender

Mensaje por Regolero el Lun 15 Feb 2016, 13:24

Genial, :resuelto2:

Pero capi, yo jamás he usado el prefligh ese, lo use una o 2 veces y lo dejé por imposible.
Regolero
Regolero
Alcaide

Rol : Director
Mensajes : 9176
Fecha de inscripción : 17/08/2010
Localización : Sevilla
. : Totems 2010: 2º Mejor Cortometraje, 2º Mejor Dirección, 2º Mejor Guión, 2º Mejor Tráiler . : Águilas 2011: 1º Mejor Ambientacion, 1º Mejor FX, 2º Mejor Sonido . : Recreaciones clásicas: The Ring

Ver perfil de usuario

Volver arriba Ir abajo

problema con Blender Empty Re: problema con Blender

Mensaje por Capitan Blackjoker el Lun 15 Feb 2016, 22:22

De nada Gabriel.
A ver Regolero, como decia no es una panacea; pero como no cuesta nada pedir un informe antes de exportar, yo me he acostumbrado a usarlo,( sobretodo cuando elimino vertices para no dejarlos sin asignar o algún fallo tonto).


problema con Blender B%2526B%2BLogo

"El Norte sin el Sur no es nada. Lo importante no es el destino ni el inicio; Solo lo es, el camino y como has viajado por él."
Capitan Blackjoker
Capitan Blackjoker
 

Mensajes : 1454
Fecha de inscripción : 17/08/2010
Localización : A bordo, como si no?
. : Águilas 2011: 2º Mejor Actor Secundario

Ver perfil de usuario

Volver arriba Ir abajo

problema con Blender Empty Re: problema con Blender

Mensaje por gabriel el Vie 26 Feb 2016, 18:45

Aprovecho este hilo para plantear una duda existencial que, a buen seguro "existe".

Vereis, ya tengo creados varios props humanos estaticos. Ya tengo un protocolo que no suele fallar: con la cabeza personalizada y el hair que deseo exporto una head. Borro. Importo la head y el custume que me interesa. Con paciencia manipulo extremidades, tronco, y finalmente cabeza (p.ej. Inclinandola). Agrupo los objets para mover el conjunto y exporto. Vale.

Ahora la duda: si en lugar de manipular vertices "a ojo" muevo la armadura (brazos, piernas, manos, torso... Lo que sea) hasta la forma deseado, el resultado es mucho mas armónico. Solo tengo que mover la head ajustandola y perfecto. Lo malo es que exporto (correctamente) pero en lugar del mesh en la forma deseada me encuentro el modelo en cruz. Supongo que debe existir una forma de que eso no ocurra pero no la se. He probado a dejar solo una de las armaduras, a vincular, a nosecuantas cosas. Imposible.

Se os ocurre algo? Porque seria la leche, vaya.

Saludos y buen findw
gabriel
gabriel
 

Mensajes : 283
Fecha de inscripción : 21/10/2010

Ver perfil de usuario

Volver arriba Ir abajo

problema con Blender Empty Re: problema con Blender

Mensaje por Capitan Blackjoker el Sáb 27 Feb 2016, 08:51

No se puede hacer. Lo siento Gabriel.
Lo que tu mueves usando el esqueleto con el modo POSE es una animación hecha con el motor gráfico del mismo Blender.
Pero la mesh no se modifica, siempre estará en la posición inicial,que si no has modificado será la de brazos en cruz.
Por eso siempre modificamos la malla y exportamos.
Pero como ves al no ser una animacion queda un poco forzada las posturas estáticas.
Una opción un poco laboriosa es hacer capturas de pantalla cuando mueves una articulación y ver como quedan los poligonos, para luego hacerlo con la malla.
Se que hay una herramienta que cuando eliges un vertice te dice en que posición se encuentra respecto al valor cero, pero desconozco si en modo Pose se pueden ver estos valores, porque no puedes ver los vertices, solo los poligonos, asi que... No se como hacerlo más preciso.


problema con Blender B%2526B%2BLogo

"El Norte sin el Sur no es nada. Lo importante no es el destino ni el inicio; Solo lo es, el camino y como has viajado por él."
Capitan Blackjoker
Capitan Blackjoker
 

Mensajes : 1454
Fecha de inscripción : 17/08/2010
Localización : A bordo, como si no?
. : Águilas 2011: 2º Mejor Actor Secundario

Ver perfil de usuario

Volver arriba Ir abajo

problema con Blender Empty Re: problema con Blender

Mensaje por gabriel el Dom 06 Mar 2016, 14:54

Pues no lo sientas. Como decia el impresentable de la coleta, "Si se puede" y con dos click:

1) importas el vestido y lo pones en modo POSE

problema con Blender Uu13CdR

2) seleccionas por partes y lo moldeas a tu gusto

problema con Blender I0KAQzU

3) vuelves a modo objeto, lo seleccionas, y te vas abajo, a MODIFIERS. Hay una ventanita y pones MAKE REAL

problema con Blender NpvfEaW

4) le das a APPLY y... voilá. La malla se conserva en la figura manipulada moviendo el esqueleto

problema con Blender NpvfEaW

5) vuelves a modo objeto y exportas. Compruebas con el MED. Resultado...

problema con Blender IWhMHmJ
problema con Blender Su52mD8

Estos son los bodys. Luego importas las cabezas personalizadas y ya esta
gabriel
gabriel
 

Mensajes : 283
Fecha de inscripción : 21/10/2010

Ver perfil de usuario

Volver arriba Ir abajo

problema con Blender Empty Re: problema con Blender

Mensaje por Regolero el Jue 10 Mar 2016, 10:04

lol aplauso el mago Gabriel jajaja, ya has aprendido más que nosotros, eso no lo sabía yo
que bien me hubiera venido esto hace años, con la de cientos de props que he tenido que mover los puntos meshes a mano porque no se me guardaba la posición 87

Tutorial yaaaaaa (yo tenía que hacer mods animados para ponerlos sentados o tumbados, etc, porque mover los puntos a mano quedaban feos, y encima desistí porque mi windons 7 me daba error los meshmanipulator, así que me va a venir muy bien esto para la parte final de mi película que necesito a muchas gente en las salas.
Regolero
Regolero
Alcaide

Rol : Director
Mensajes : 9176
Fecha de inscripción : 17/08/2010
Localización : Sevilla
. : Totems 2010: 2º Mejor Cortometraje, 2º Mejor Dirección, 2º Mejor Guión, 2º Mejor Tráiler . : Águilas 2011: 1º Mejor Ambientacion, 1º Mejor FX, 2º Mejor Sonido . : Recreaciones clásicas: The Ring

Ver perfil de usuario

Volver arriba Ir abajo

problema con Blender Empty Re: problema con Blender

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 1 de 2. 1, 2  Siguiente

Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.