Foro The Movies Cinema Machinima Español
BIENVENIDO a la comunidad sobre el juego The Movies y otros Machinimas. Aquí encontraras una gran familia, ayuda, etc, y sobre todo compartir la afición que nos gusta a todos, que es crear películas con motores de juegos. Regístrate o identifícate para quitar la publicidad y poder participar en el foro.
Si tienes problemas con el registro, en el foro Bienvenidos hay un post-it abierto a invitados.
------------------------------------------------------------
WELCOME to the community about the game The Movies and other Machinimas. Here you will find a great family, help, etc, and above all share the hobby that we like to all, which is to create movies with game engines. Register or identify to remove the publicity and to participate in the forum. If you have problems with the registration, in the Welcome forum there is a post-it open to guests.

Un prop autoanimado me da problemas

Página 1 de 3. 1, 2, 3  Siguiente

Ir abajo

Un prop autoanimado me da problemas

Mensaje por kubo10 el Miér 24 Oct 2018, 09:05

Estoy convirtiendo todos los actores de mi siguiente peli en props autoanimados y me falta una actriz que me da problemas. Es de los famosos costumes de actor completo de Steve45. Los demás han sido muy fáciles de convertir. Borrar los huesos de ojos, boca y cara, asignarlos a la cabeza, darle a autoanimar y listo. Pero ésta, aunque la autoanimación la realiza bien, parece que el cuello se estirase en altura, como se ve en la imagen:



Tiene la peculiaridad de que, a diferencia de los otros, el mesh de la cabeza incluye brazos y cuello:



No obstante, hago lo de siempre, borro todos los huesos de la cara (fa_), incluso, por si acaso, borro el hueso de la cabeza, cojo todos los vértices bien, vuelvo a crear el hueso de la cabeza y los asigno.



Incluso pruebo con el truquillo que nos enseñó Regolero de pulsar "H", después seleccionar los huesos de head, neck y chest para que no se vean los vértices seleccionados. Ni un sólo punto sin asignar (de hecho se exporta correctamente sin dar error). Los brazos y todo, están bien asignados (el trozito de brazo que se ven vértices es del control2_arm)



Dejo todo visible de nuevo, funciona todo en modo pose, exporto asegurándome de que esté en modo objeto, paso por el MED y luego en el juego se ve lo de arriba... La animación bien pero la cabeza estirada.
¿Alguna idea?
avatar
kubo10
 

Rol : Director
Mensajes : 2792
Fecha de inscripción : 28/01/2015
Localización : Cantabria

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por Regolero el Miér 24 Oct 2018, 10:49

Eso casi seguro se debe a que tienes vértices asignados a verios huesos a la misma vez.

Ya lo he dicho un montón de veces, los vértices solo a un hueso (aunque los originales del juego vienen asignados a varios huesos, y el movimiento es más bueno, los que nosotros creamos, nose porque, le pasa esto, así que tienes que cojer en blender y seleccionar los de la cabeza (con ellos seleccionados, vas pasando por todos los huesos y dándole a desvincular o eliminar de ese hueso)
Luego cojes los de la espalda y los seleccionas todos, y la misma rutina, hueso a hueso eliminando esos seleccionados, hasta que estén borrados de los otros huesos todos los vértices

Acuerdate, cuando hagas el proceso con los vértices de un hueso, deseleccionalos todos antes de seleccionar los del nuevo hueso.
avatar
Regolero
Alcaide

Rol : Director
Mensajes : 8965
Fecha de inscripción : 17/08/2010
Localización : Sevilla
. : Totems 2010: 2º Mejor Cortometraje, 2º Mejor Dirección, 2º Mejor Guión, 2º Mejor Tráiler . : Águilas 2011: 1º Mejor Ambientacion, 1º Mejor FX, 2º Mejor Sonido

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por kubo10 el Miér 24 Oct 2018, 11:45

Que todos los vértices estén asignados a huesos lo tengo claro (para empezar no da error), pero sí que puede haber ocurrido lo que dices, que alguno esté asignado a dos. Voy a hacer lo que cuentas y luego informo good

Muchas gracias.
avatar
kubo10
 

Rol : Director
Mensajes : 2792
Fecha de inscripción : 28/01/2015
Localización : Cantabria

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por Regolero el Miér 24 Oct 2018, 12:48

ok, mantén informado.

Si ves que te haces un poco de lío, o no sabes a lo que me refiero en la explicación, me lo dices, y te hago un pequeño video rápido.
avatar
Regolero
Alcaide

Rol : Director
Mensajes : 8965
Fecha de inscripción : 17/08/2010
Localización : Sevilla
. : Totems 2010: 2º Mejor Cortometraje, 2º Mejor Dirección, 2º Mejor Guión, 2º Mejor Tráiler . : Águilas 2011: 1º Mejor Ambientacion, 1º Mejor FX, 2º Mejor Sonido

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por kubo10 el Miér 24 Oct 2018, 12:50

Sí, si, ahora mismo estaba probando.
Te refieres a escoger por ejemplo el hueso head, darle a Selec para que marque todos los vértices, coger otros huesos como neck, chest... e irle dando a deselec para que no estén en ambos huesos. Lo tengo claro, lo que pasa es que tengo otra teoría que voy a probar ahora...
avatar
kubo10
 

Rol : Director
Mensajes : 2792
Fecha de inscripción : 28/01/2015
Localización : Cantabria

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por kubo10 el Miér 24 Oct 2018, 12:56

Pues nada, creo que he repasado todo y no hay vértices comunes (creo), al menos no en cabeza, pecho, cuello y brazos. Tenía la teoría de que no encontraba el hueso root por ningún lado y pensé que ahí estaba el problema. Lo he creado y asginado vértices en la zona pero sigue igual, cabeza alargada.

Abandono de momento para ir a comer, no sé si luego retomaré o lo mandaré a la porra mellado   Es un prop que no necesito demasiado, era sólo por el reto de que, después de haber convertido 8 individuos para la peli, no sé porque falla sólo esta.

Edito: Lo que fuera que tuviera en la cabeza para que se ha desplazado a los brazos. He estado vago y pensando que al salir la cabeza alargada, sería vértices en conflicto en head, neck y por ahí. Está claro que tendré que mirar todos los huesos uno a uno:

avatar
kubo10
 

Rol : Director
Mensajes : 2792
Fecha de inscripción : 28/01/2015
Localización : Cantabria

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por Dibujante el Miér 24 Oct 2018, 13:42

En teoría has hecho todos los pasos asequibles para que no te pase.

Ayer al hacer yo un prop autoanimado se me veían estirados los ojos y boca (porque tenían sus propios huesos y no entraban en la animación). En teoría es borrar sus asignaciones y ponerlo todo en 'head'. Vigila de cerca, no obstante, que esté puesto el neckconnect.

Y, para descartar, ¿se está reproduciendo una .anm sin alterar el tamaño del armature, verdad? (No es gigante ni enano).

Mueve al personaje en Blender para ver si se queda estirado alguna parte. Selecciona esa parte (si tienes el costume separado por MESHES) para ver en cuál está el fallo, y luego prueba a seleccionar cada uno de los huesos asignados hasta que demos cuál es el que da problemas.
avatar
Dibujante
 

Rol : Director
Mensajes : 5431
Fecha de inscripción : 13/02/2011
Localización : Murcia

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por kubo10 el Miér 24 Oct 2018, 15:45

No hay neckconnect, ¿tiene que estar? el modelo original no lo tiene y no da problemas como costume. Es una animación normal, no se ha alterado el tamaño de nada
Muevo todo en modo pose y parece estar bien. Casi ya lo dejo por imposible y paso a otra cosa mellado
avatar
kubo10
 

Rol : Director
Mensajes : 2792
Fecha de inscripción : 28/01/2015
Localización : Cantabria

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por Dibujante el Miér 24 Oct 2018, 21:03

Pásame el modelo y el archivo .blend tal cual lo has dejado (con todos sus componentes: la animación y el MESH).

PD: Rescátalo de la papelera de reciclaje aunque lo hayas borrado.
avatar
Dibujante
 

Rol : Director
Mensajes : 5431
Fecha de inscripción : 13/02/2011
Localización : Murcia

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por Dibujante el Miér 24 Oct 2018, 21:04

Pásame el modelo y el archivo .blend tal cual lo has dejado (con todos sus componentes: la animación y el MESH).

PD: Rescátalo de la papelera de reciclaje aunque lo hayas borrado.
avatar
Dibujante
 

Rol : Director
Mensajes : 5431
Fecha de inscripción : 13/02/2011
Localización : Murcia

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 1 de 3. 1, 2, 3  Siguiente

Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.