Foro The Movies Cinema Machinima Español
BIENVENIDO a la comunidad sobre el juego The Movies y otros Machinimas. Aquí encontraras una gran familia, ayuda, etc, y sobre todo compartir la afición que nos gusta a todos, que es crear películas con motores de juegos. Regístrate o identifícate para quitar la publicidad y poder participar en el foro.
Si tienes problemas con el registro, en el foro Bienvenidos hay un post-it abierto a invitados.
------------------------------------------------------------
WELCOME to the community about the game The Movies and other Machinimas. Here you will find a great family, help, etc, and above all share the hobby that we like to all, which is to create movies with game engines. Register or identify to remove the publicity and to participate in the forum. If you have problems with the registration, in the Welcome forum there is a post-it open to guests.

Un prop autoanimado me da problemas

Página 3 de 3. Precedente  1, 2, 3

Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por Dibujante el Jue 25 Oct 2018, 17:36



O quizá no mellado mellado mellado

Dibujante
 

Mensajes : 5431
Fecha de inscripción : 13/02/2011

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por kubo10 el Jue 25 Oct 2018, 17:44

Claro, es que en eso estoy todo el rato, lo que pasa es que no me creías... Eres como Santo Tomás, hasta que no has visto, no has creído mellado 

Si se mete como costume, o sea, como nos lo dejó Steve45, sale bien.
Si se mete como prop autoanimado después de borrar los huesos de la cara y reasignar, sale eso (cabeza alargada).

Y si la metes como prop autoanimado sin tocar lo de Steve45 (sólo activando el autoanimated), ocurrirá esto:


Dices que no tiene que influir pero SIEMPRE que no he borrado los huesos de la cara para un prop autoanimado me ha pasado esto. Ya sé que no tienen sincro.
avatar
kubo10
 

Rol : Director
Mensajes : 2791
Fecha de inscripción : 28/01/2015
Localización : Cantabria

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por Dibujante el Jue 25 Oct 2018, 17:53

Pues a primera vista no lo he podido solucionar, kubo.

Tiene la peculiaridad de que se ve estirado y parece como si fuera de la zona de la boca y los ojos. Parece como el dilema de la textura estirada, solo que en un prop autoanimado. Ya no le puedo dedicar más tiempo. Por simple curiosidad, podríamos probar otra animación o quitarle la boca (ya que no hablan), o emparentarle un prop del juego (sin asociado de huesos). No creo que te funcionen estas tres propuestas mellado

Déjalo pendiente para que con más tiempo y más personas lo revisen a ver si salimos de dudas good
avatar
Dibujante
 

Rol : Director
Mensajes : 5431
Fecha de inscripción : 13/02/2011
Localización : Murcia

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por kubo10 el Jue 25 Oct 2018, 18:06

He probado otras animaciones y probé hace un par de días a meterle un prop del juego por si era algo estilo "texturas estiradas", pero nada.

No pasa nada, te agradezco el tiempo que le has dedicado good

Ni siquiera es un impedimento para sacar adelante la película. Simplemente es una de esas cosas que quieres resolver por el mero hecho de saber donde estaba el problema.

Gracias good
avatar
kubo10
 

Rol : Director
Mensajes : 2791
Fecha de inscripción : 28/01/2015
Localización : Cantabria

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por Dibujante el Jue 25 Oct 2018, 21:40

Es posible que alguna vez me haya sucedido algo parecido, pero sería hace tanto tiempo que no sé si lo solucioné o lo dejé pasar. Lo dejaremos pendiente, por pura curiosidad.

Gracias a ti que me has arreglado el Blender en el proceso mellado
avatar
Dibujante
 

Rol : Director
Mensajes : 5431
Fecha de inscripción : 13/02/2011
Localización : Murcia

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por Regolero el Sáb 27 Oct 2018, 10:37

Pásamelo a mi kubo, que veo, que algunos van de que saben mucho pero al final ....

Y a todo esto, leyendo los últimos post, vuelvo a repetir por 500 vez, jamás de los jamases utilizéis neckconnect, yo siempre borro ese hueso. Siempre ha dado error de export el utilizar ese hueso, o luego error en el juego. Igual que nunca uso los huesos de los hombros. Incluso root es muy raro que lo use.

Y los props animados pues como ya habéis visto, siempre con el esqueleto normal, no con el de la cara.

El problema de tu mod tiene que ser lo que ya te dije de vértices asignados a distintos huesos, es más, has visto que al desasociar los de la cabeza, etc ya no tienes los pinchos hacia arriba, pero es porque no está ahí el problema, hay que seguir mirando huesos, seguramente sea gut o algo, aunque ahora que te sale en los hombros, pues seguro es que ese costume se ha pegado a los huesos automáticamente y todos los vértices del costume están pegados a distintos huesos.

Así que lo más fácil va a ser coger y crearlo como nuevo, desasociando todo y pegarlo desde 0 a los huesos manualmente, acabarás antes y se solucionará seguro, no hay más fallo, es lo que te digo. (Para algo vale la experiencia de cientos de errores haciendo mods)
avatar
Regolero
Alcaide

Rol : Director
Mensajes : 8965
Fecha de inscripción : 17/08/2010
Localización : Sevilla
. : Totems 2010: 2º Mejor Cortometraje, 2º Mejor Dirección, 2º Mejor Guión, 2º Mejor Tráiler . : Águilas 2011: 1º Mejor Ambientacion, 1º Mejor FX, 2º Mejor Sonido

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por kubo10 el Dom 28 Oct 2018, 18:58

Este es el enlace:

https://app.box.com/s/sysl4cpa8zs96hvjc8qr0zkji9scwd7l

Las carpetas costume, meshes y textures son tal cual las tiene el modelo original de Steve45. Hay un .blend con el modelo original sin tocar nada (sigue teniendo hasta los huesos de la cara) aparte de que es el modelo con los accesorios que va a llevar, con todo emparentado dentro del armature

Aparte están el .msh y la .anm de la última prueba que he hecho, con el archivo 2.blend. Esta última prueba consistió en seleccionar todos los vértices de huesos de la cara, asignarlos al hueso de la cabeza, borrar todos los huesos de la cara y no tocar nada más, dejarlo todo tal cual lo tiene Steve45.

Te digo lo mismo que a Dibujante, que no te quite tiempo. Tengo rodado el 40% de la peli y no he necesitado este prop autoanimado, me arreglo bien sin él, así que tampoco te tomes demasiadasa molestias. Gracias good
avatar
kubo10
 

Rol : Director
Mensajes : 2791
Fecha de inscripción : 28/01/2015
Localización : Cantabria

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por Regolero el Dom 28 Oct 2018, 19:04

La cosa va a ser lo que te dije. Habrá que pegar de 0 el costume a los huesos manualmente y dejará de dar error.
avatar
Regolero
Alcaide

Rol : Director
Mensajes : 8965
Fecha de inscripción : 17/08/2010
Localización : Sevilla
. : Totems 2010: 2º Mejor Cortometraje, 2º Mejor Dirección, 2º Mejor Guión, 2º Mejor Tráiler . : Águilas 2011: 1º Mejor Ambientacion, 1º Mejor FX, 2º Mejor Sonido

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por kubo10 el Dom 28 Oct 2018, 19:09

Me da un poco de cosa el pegar de cero porque siempre me queda mal, con el hombro "cuadriculado" cuando está en posición de descanso. Creo que eso era el famoso control_arm

Probaré, pero vamos, que ha caído en mi lista de prioridades mellado  Estoy a ver si acabo rápido de filmar la peli  good
avatar
kubo10
 

Rol : Director
Mensajes : 2791
Fecha de inscripción : 28/01/2015
Localización : Cantabria

Ver perfil de usuario

Volver arriba Ir abajo

Re: Un prop autoanimado me da problemas

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 3 de 3. Precedente  1, 2, 3

Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.