Foro The Movies Cinema Machinima Español
BIENVENIDO a la comunidad sobre el juego The Movies y otros Machinimas. Aquí encontraras una gran familia, ayuda, etc, y sobre todo compartir la afición que nos gusta a todos, que es crear películas con motores de juegos. Regístrate o identifícate para quitar la publicidad y poder participar en el foro.
Si tienes problemas con el registro, en el foro Bienvenidos hay un post-it abierto a invitados.
------------------------------------------------------------
WELCOME to the community about the game The Movies and other Machinimas. Here you will find a great family, help, etc, and above all share the hobby that we like to all, which is to create movies with game engines. Register or identify to remove the publicity and to participate in the forum. If you have problems with the registration, in the Welcome forum there is a post-it open to guests.

[Resuelto]problema exportacion blender

Página 2 de 3. Precedente  1, 2, 3  Siguiente

Ir abajo

Re: [Resuelto]problema exportacion blender

Mensaje por RyogaVLC el Vie 21 Ene 2011, 02:10

mira aqui estan todos los pogramas de modding de the movies incluidos el scrip de blender mira si tienes lo mismos

http://www.themoviescinema.com/t67-programas-para-modding

RyogaVLC
 

Mensajes : 1041
Fecha de inscripción : 17/08/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: [Resuelto]problema exportacion blender

Mensaje por Capitan Blackjoker el Vie 21 Ene 2011, 15:07

hola buenas.

Yo tengo instalados los scripts 2009 y me pasaba lo mismo, al parecer (por mi poca experiencia) es el nombre assignado a la textura que supera el valor de 32 ¿?, yo lo soluciono con el truco de cambiar la textura que se assigna al mesh, para exportarla y luego con el MED le vuelvo a poner la texutra que me interesa. Prueba este truco a ver si tienes tanta suerte como yo.

Nos vemos.




"El Norte sin el Sur no es nada. Lo importante no es el destino ni el inicio; Solo lo es, el camino y como has viajado por él."
avatar
Capitan Blackjoker
 

Mensajes : 1454
Fecha de inscripción : 17/08/2010
Localización : A bordo, como si no?
. : Águilas 2011: 2º Mejor Actor Secundario

Ver perfil de usuario

Volver arriba Ir abajo

Re: [Resuelto]problema exportacion blender

Mensaje por soulmangroove el Vie 21 Ene 2011, 15:10

Si si los de 2009, ademas sino crecuerdo mal creo que los descargue de aqui
desinstalare el blender y lo volvere a instalar y le metere de nuevo los script. un saludo ya os cuento!

soulmangroove
 

Mensajes : 15
Fecha de inscripción : 19/01/2011

Ver perfil de usuario

Volver arriba Ir abajo

Re: [Resuelto]problema exportacion blender

Mensaje por Regolero el Vie 21 Ene 2011, 21:22

eso del 32 creo que son los caracteres osea letras del nombre, si un archivo bien un mesh textura o algo tiene muchos caracteres da error en blender (incluso algunos tambien en the movies)

tambien ay que tener cuidado con los nombres que no contengan la letra ñ ni espacios good
avatar
Regolero
Alcaide

Rol : Director
Mensajes : 8565
Fecha de inscripción : 17/08/2010
Localización : Sevilla
. : Totems 2010: 2º Mejor Cortometraje, 2º Mejor Dirección, 2º Mejor Guión, 2º Mejor Tráiler . : Águilas 2011: 1º Mejor Ambientacion, 1º Mejor FX, 2º Mejor Sonido

Ver perfil de usuario

Volver arriba Ir abajo

Re: [Resuelto]problema exportacion blender

Mensaje por soulmangroove el Vie 21 Ene 2011, 21:37

´si está claro que es lo del nombre, pero seria raro que pase con todos los mes que he probado...ya que los nombres se los da el juego no yo... seguire indagando jaja

soulmangroove
 

Mensajes : 15
Fecha de inscripción : 19/01/2011

Ver perfil de usuario

Volver arriba Ir abajo

Re: [Resuelto]problema exportacion blender

Mensaje por Regolero el Vie 21 Ene 2011, 21:47

si son originales the movies no deberia de tener ningun error,,,,,,,,, primero si te importa sin error es que esta bien.

puede que el problema este en la modificacion que le hayas echo,,,,,,,,, asi que si puedes esplica un poco lo que hiciste o bien intenta lo que te comento fincher
avatar
Regolero
Alcaide

Rol : Director
Mensajes : 8565
Fecha de inscripción : 17/08/2010
Localización : Sevilla
. : Totems 2010: 2º Mejor Cortometraje, 2º Mejor Dirección, 2º Mejor Guión, 2º Mejor Tráiler . : Águilas 2011: 1º Mejor Ambientacion, 1º Mejor FX, 2º Mejor Sonido

Ver perfil de usuario

Volver arriba Ir abajo

Re: [Resuelto]problema exportacion blender

Mensaje por soulmangroove el Sáb 22 Ene 2011, 00:03

esque me da error hasta sin modificarlo, no se macho, mañana reinstalare y le metere de nuevo los script

soulmangroove
 

Mensajes : 15
Fecha de inscripción : 19/01/2011

Ver perfil de usuario

Volver arriba Ir abajo

Re: [Resuelto]problema exportacion blender

Mensaje por soulmangroove el Sáb 22 Ene 2011, 12:32

ya me sale lo del preflight y me sale esto:


Traceback (most recent call last):
File "D:\Programas\Edicion\3d\Blender\.blender\scripts\tm_preflight.py", line 66, in test
self.assertTrue(has in list,msg)
AssertionError: Mesh '_hideon_1.02.000' is not in a Blender Group. Add it to a group.

y esto es lo que dice cada fail

soulmangroove
 

Mensajes : 15
Fecha de inscripción : 19/01/2011

Ver perfil de usuario

Volver arriba Ir abajo

Re: [Resuelto]problema exportacion blender

Mensaje por Capitan Blackjoker el Sáb 22 Ene 2011, 12:55

Hola buenas.
Usaré metaforas para que entendaís lo que yo creo que ocurre después de tantas veces como me ha ocurrido esto a mi.

Recordad que hay dos scripts: uno importa y el otro exporta.
El script de importar "lee" el material original del juego y se lo "traduce" al blender para que podamos usarlo.

El script de exportar "lee" lo del blender y lo "escribe" de nuevo todo para que el juego o el MED lo "lea".


Fijaos que algunos mods, incluyen texturas en formato .png, pero ironicamente cuando exportas estas texturas no son reconocidas ni por el Med ni en el juego,considerando las mesh "corruptas".
Lo mismo ocurre con los nombres de las texturas: Para entrar en blender si que las "lee" pero al "salir" no salen.¿Cómo es posible?

Esta es mi teoria:
Los chicos que hicieron estos scripts, cometieron el error de que las texturas para "salir" del blender deben cumplir dos requisitos si queremos que funcionen:

No superar los 32 caracteres de nombre y que sean de formato .dds.

Pero como digo el juego tiene texturas .png y algunas con nombres largos. Tened mucho cuidado cuando importéis elementos originales del juego y comprobad TODAS LAS TEXTURAS. Liado el tema, verdad?

Asi que resumiendo: Cambiar las texturas con el MED (no importa si no son las definitivas) y luego usad el blender para luego de exportarlas, usad de nuevo el MED para colocarle las texturas definitivas( que no importa su longitud pero que sean SIEMPRE .DDS).

Por cierto si modificáis cosas de la mesh tened cuidado de associar las texturas a los objetos y los objetos a un empty o quedaran como un elemento "huerfano". Eso puedes ser la causa de que a soulmangroove le diga que ese mesh no pertenece a ningun grupo de Blender: los objeros deben esta "emparentados" a algo. Para más infomación sobre eso pasad por la tutorial de Regolero de como añadir cosas a los vestidos.

Ya me dirás.
Nos vemos




"El Norte sin el Sur no es nada. Lo importante no es el destino ni el inicio; Solo lo es, el camino y como has viajado por él."
avatar
Capitan Blackjoker
 

Mensajes : 1454
Fecha de inscripción : 17/08/2010
Localización : A bordo, como si no?
. : Águilas 2011: 2º Mejor Actor Secundario

Ver perfil de usuario

Volver arriba Ir abajo

Re: [Resuelto]problema exportacion blender

Mensaje por soulmangroove el Sáb 22 Ene 2011, 15:58

ahora no me da error al exportar, pero cuando vuelvo a importar el anterior archivo no sale nada...estoy hasta los güebos del puto blender

soulmangroove
 

Mensajes : 15
Fecha de inscripción : 19/01/2011

Ver perfil de usuario

Volver arriba Ir abajo

Re: [Resuelto]problema exportacion blender

Mensaje por Regolero el Sáb 22 Ene 2011, 17:39

he visto que lo que has usado es un set, la bluescreen no suele dar error, pero la mayoria de sets dan error en blender, y aunque no te lo creas depende del dia, ay dias que lo importa todo sin ninguno error y otros dias que da error por todo, misterios de la informatica jajajja.

prueba con props normales a ver si siguen los errores, si se soluciono es que es cosa de los sets como ya digimos.

el dia que lo importe todo sin errores es bueno guardarlo todo en blend y asi lo tienes para siempre porque el dia que mas prisa te corra te dara error 123
avatar
Regolero
Alcaide

Rol : Director
Mensajes : 8565
Fecha de inscripción : 17/08/2010
Localización : Sevilla
. : Totems 2010: 2º Mejor Cortometraje, 2º Mejor Dirección, 2º Mejor Guión, 2º Mejor Tráiler . : Águilas 2011: 1º Mejor Ambientacion, 1º Mejor FX, 2º Mejor Sonido

Ver perfil de usuario

Volver arriba Ir abajo

Re: [Resuelto]problema exportacion blender

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 2 de 3. Precedente  1, 2, 3  Siguiente

Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.