Foro The Movies Cinema Machinima Español
BIENVENIDO a la comunidad sobre el juego The Movies y otros Machinimas. Aquí encontraras una gran familia, ayuda, etc, y sobre todo compartir la afición que nos gusta a todos, que es crear películas con motores de juegos. Regístrate o identifícate para quitar la publicidad y poder participar en el foro.
Si tienes problemas con el registro, en el foro Bienvenidos hay un post-it abierto a invitados.
------------------------------------------------------------
WELCOME to the community about the game The Movies and other Machinimas. Here you will find a great family, help, etc, and above all share the hobby that we like to all, which is to create movies with game engines. Register or identify to remove the publicity and to participate in the forum. If you have problems with the registration, in the Welcome forum there is a post-it open to guests.
Foro The Movies Cinema Machinima Español
¿Quieres reaccionar a este mensaje? Regístrate en el foro con unos pocos clics o inicia sesión para continuar.

MED no me carga todas las texturas

Página 1 de 3. 1, 2, 3  Siguiente

Ir abajo

MED no me carga todas las texturas Empty MED no me carga todas las texturas

Mensaje por fshtravis el Dom 16 Ago 2020, 01:10

Buenos días, estoy intentando convertir un modelo de sketchup a The movies pero cuando lo abro con MED no me carga todas las texturas. Las que me deja cambiar, he convertido los jpg a dds y perfecto, pero la mayor parte del prop se queda en color blanco. Adjunto foto para que lo veáis.

El modelo es este: https://3dwarehouse.sketchup.com/model/uf9824c71-c287-4e93-ac81-7b34c68ecba5/Supermercado-AhorraMas

Como podéis observar me da a elegir muy pocas texturas.

MED no me carga todas las texturas JnOMVdF

Cómo puedo solucionarlo?

Muchas gracias a todos!
Saludos
fshtravis
fshtravis
 

Mensajes : 235
Fecha de inscripción : 02/11/2011

Volver arriba Ir abajo

MED no me carga todas las texturas Empty Re: MED no me carga todas las texturas

Mensaje por Regolero el Dom 16 Ago 2020, 08:58

habría que ver quizás el modelo que has convertido, para ver si lo has convertido bien o no, o si todo lo blanco es un solo mesh, y aunque te salgan ahí varias para cambiar solo tiene asociada 1 y el resto está ahí para nada.
Regolero
Regolero
Alcaide

Rol : Director
Mensajes : 10309
Fecha de inscripción : 17/08/2010
Localización : Sevilla
. : Totems 2010: 2º Mejor Cortometraje, 2º Mejor Dirección, 2º Mejor Guión, 2º Mejor Tráiler . : Águilas 2011: 1º Mejor Ambientacion, 1º Mejor FX, 2º Mejor Sonido . : Recreaciones clásicas: The Ring

Volver arriba Ir abajo

MED no me carga todas las texturas Empty Re: MED no me carga todas las texturas

Mensaje por fshtravis el Dom 16 Ago 2020, 12:10

Buenas Regolero, he usado otro modelo de sketvhup y me pasa lo mismo: Las texturas de las paredes principales se ven en blanco.

Con el programa de sketchup lo exporto a obj y luego en el blender sigo el tutorial que hiciste. Y a priori no veo nada raro de estar haciendo mal.

Si alguno puede echarle un ojo en cinco minutos se lo agradezco.

El modelo es este: https://3dwarehouse.sketchup.com/model/uf9824c71-c287-4e93-ac81-7b34c68ecba5/Supermercado-AhorraMas

Este es el mesh que me generó blender: https://ufile.io/9yxaldw1

Muchas gracias a todos.
fshtravis
fshtravis
 

Mensajes : 235
Fecha de inscripción : 02/11/2011

Volver arriba Ir abajo

MED no me carga todas las texturas Empty Re: MED no me carga todas las texturas

Mensaje por DibujanteTM el Dom 16 Ago 2020, 13:25

Hola fshtravis,

A priori, si el MED carga las texturas en el listado es porque las detecta. Si el modelo se ve en blanco, es porque los 'materiales' asociados a dichas texturas no están seleccionados.

Tendrías que hacer click en la pestaña 'Materials', que la tienes arriba de donde el listado de texturas. Y ahí, vas cambiando el número de Material y te fijas que donde pone 'Diffuse' aparezca el nombre de alguna textura. Como lo más probable es que te salga en blanco, tendrías que desplegarla y asignar manualmente la textura fijándote en que quede bien en el modelo.

Algunos vídeos que te pueden ser de utilidad:

https://www.youtube.com/watch?v=PGbYktyozg0&feature=emb_title

https://www.youtube.com/watch?v=mUKpA5v_ioE&feature=emb_title

Ahora, si nos ponemos profesionales, el trabajo tendría que mejorarse desde el propio Blender, donde es conveniente que, al convertir el modelo, le pongas el modo textura para asegurarte de que se ven todas las texturas convenientemente.

En efecto, el sketchup lo usábamos y todavía ofrece buenos modelos, pero hoy por hoy existen opciones más alternativas y de mayor calidad que incluso ya te vienen en .obj. Yo, por si deseas echarle un vistazo, te lo dejo aquí: https://www.themoviescinema.com/t2527-taller-1-conversion-de-archivos-xnalara-a-props

En dicho taller también están los vídeos que te he colocado, así como otras cuestiones que te podrían surgir durante la conversión.

Por último, nuestros coleccionados de 'errores' y soluciones que nunca están de más echar un vistazo:

https://www.themoviescinema.com/t1335-coleccionado-guia-de-errores-y-soluciones-blender?highlight=errores+blender

https://www.themoviescinema.com/t1300-coleccionado-guia-de-errores-y-soluciones-med?highlight=Errores+MED

Un saludo.
DibujanteTM
DibujanteTM
 

Rol : Director
Mensajes : 7189
Fecha de inscripción : 13/02/2011
Localización : Murcia
. : Recreaciones clásicas: El Planeta de los Simios, Ciudadano Kane

Volver arriba Ir abajo

MED no me carga todas las texturas Empty Re: MED no me carga todas las texturas

Mensaje por fshtravis el Dom 16 Ago 2020, 13:59

Muchas gracias!!!! He hecho lo del video y he conseguido poner texturas a lo blanco. Ahora, soy un novato en blender, pero me gustaría separar el techo, el logo de Ahorramas y el suelo. La misma textura se aplica en esas tres partes. ¿Es complicado hacerlo?

Además de que solo puedo poner una textura de las que he elegido para el resto de partes. NO sé si me explico. No puedo seleccionar una nueva textura para las partes en blanco, tengo usar las que ya he cargado para el resto del prop.

Un saludo!

Edit: Estoy mirando la web que has pasado, y tiene modelos espectaculares, pero no encuentro cómo filtrar los resultados que quiero. Estoy buscando el exterior de un supermercado!
fshtravis
fshtravis
 

Mensajes : 235
Fecha de inscripción : 02/11/2011

Volver arriba Ir abajo

MED no me carga todas las texturas Empty Re: MED no me carga todas las texturas

Mensaje por fshtravis el Dom 16 Ago 2020, 15:05

Estoy haciendo pruebas. El Sketchup no me exporta todas las texturas. Paso fotos:

MED no me carga todas las texturas Vmdigx4

Las imágenes que me exporta son solo esas:

MED no me carga todas las texturas GlaChRA

En modo textura se ve así:

MED no me carga todas las texturas JDrwpy7

Y en modo sólido:

MED no me carga todas las texturas JVcjdD2


El modelo es este: https://3dwarehouse.sketchup.com/model/u55117784-cede-4031-b68d-6a601464524d/CARREFOUR-BAIRRO-CATANDUVA-SP

Si lo paso al MED se verá todo blanco y no podré elegir las texturas para cada una de las zonas.
fshtravis
fshtravis
 

Mensajes : 235
Fecha de inscripción : 02/11/2011

Volver arriba Ir abajo

MED no me carga todas las texturas Empty Re: MED no me carga todas las texturas

Mensaje por kubo10 el Dom 16 Ago 2020, 18:17

Yo no tengo mucha experiencia con sketchup, pero me suena que alguna vez me dió problemas con texturas que faltaban, igual que a ti.

Valdría este exterior de tienda? https://www.deviantart.com/amiamy111/art/MMD-Friendly-Market-stage-481198786
Porque si se trata de exterior de centro comercial grande, creo que había alguno subido.

No hay filtro para los modelos de Xnalara, aunque están organizados en categorías en deviantart, pero no creo que te sea muy útil. Yo suelo buscar en google lo que necesito acompañado de "xnalara" e incluso "deviantart" y me muevo entre las imágenes.
kubo10
kubo10
 

Rol : Director
Mensajes : 6374
Fecha de inscripción : 28/01/2015
Localización : Cantabria
. : Recreaciones clásicas: Psicosis, Pulp Fiction El Planeta de los Simios, mejor recreación general.

Volver arriba Ir abajo

MED no me carga todas las texturas Empty Re: MED no me carga todas las texturas

Mensaje por fshtravis el Dom 16 Ago 2020, 18:51

@kubo10 escribió:Yo no tengo mucha experiencia con sketchup, pero me suena que alguna vez me dió problemas con texturas que faltaban, igual que a ti.

Valdría este exterior de tienda? https://www.deviantart.com/amiamy111/art/MMD-Friendly-Market-stage-481198786
Porque si se trata de exterior de centro comercial grande, creo que había alguno subido.

No hay filtro para los modelos de Xnalara, aunque están organizados en categorías en deviantart, pero no creo que te sea muy útil. Yo suelo buscar en google lo que necesito acompañado de "xnalara" e incluso "deviantart" y me muevo entre las imágenes.

Buenas Kubo! Ante todo, muchas gracias por los consejos!

Sí, quiero un exterior de centro comercial/supermercado. El de devianart me podría valer, aunque el de Sketchup es perfecto porque es una marca "española" (mi historia se desarrola en una ciudad como Madrid). Pero a muy malas puedo usarlo. Muchas gracias!

El caso es que por 2012 recuerdo usar el sketchup (el interfaz era muy diferente) y haber conseguido crear propset sin muchas dificultades.
fshtravis
fshtravis
 

Mensajes : 235
Fecha de inscripción : 02/11/2011

Volver arriba Ir abajo

MED no me carga todas las texturas Empty Re: MED no me carga todas las texturas

Mensaje por kubo10 el Dom 16 Ago 2020, 18:58

En cualquier caso, abriendo la textura adecuada con Photoshop, paint.net o cualquier otro programa de edición de imagen, le puedes cambiar logos, nombres o lo que te interese, como ya sabrás good

En el caso concreto del modelo que estás intentando convertir, entiendo que no te saca las otras texturas porque son colores sólidos. Es decir, no son imágenes de texturas como tales si no que está "pintado" en el modelo y esa información no se exporta luego. No tengo ni idea, a lo mejor me equivoco, pero creo que es lo que me pasaba a mí.

En cuánto a que luego no se vean en blender en modo textura (que lo que veas ahí es lo que vas a abrir luego en MED normalmente), puede ser que no te esté sacando el archivo mtl al convertir a obj, o que no lo esté haciendo correctamente. Ese archivo es el que le da la información a blender con el listado de texturas.
kubo10
kubo10
 

Rol : Director
Mensajes : 6374
Fecha de inscripción : 28/01/2015
Localización : Cantabria
. : Recreaciones clásicas: Psicosis, Pulp Fiction El Planeta de los Simios, mejor recreación general.

Volver arriba Ir abajo

MED no me carga todas las texturas Empty Re: MED no me carga todas las texturas

Mensaje por fshtravis el Dom 16 Ago 2020, 19:16

Muchas gracias Kubo por lo que me estás contando. El archivo mtl me lo crea! He exportado en el sketchup el modelo a 3ds y en el 3dstudio max lo abre perfectamente, pero cuando lo exporto a obj me da error. No hay manera Sad
fshtravis
fshtravis
 

Mensajes : 235
Fecha de inscripción : 02/11/2011

Volver arriba Ir abajo

MED no me carga todas las texturas Empty Re: MED no me carga todas las texturas

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 1 de 3. 1, 2, 3  Siguiente

Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.